Pyllars

Latest version: v1.0.5

Safety actively analyzes 600401 Python packages for vulnerabilities to keep your Python projects secure.

Scan your dependencies

Page 1 of 4

1.0.5

Fixed
- Incorrect requirements version of scikit-learn

1.0.4

Added
- Helper for counting group sizes in pandas
- Helper for extracting values from config-like mappings
- Helpers for sampling from conjugate distributions
- Hyperparameter grids for standard models
- Helper for cross product of pandas data frame

Updated
- xgb_utils to be compatible with `xgboost > 1.0
- torch_utils to handle missing directories in IO operations
- xgb_utils to accommodate arbitrary hyperparameters

Fixed
- Incorrect import in incremental count vectorizer
- Default parameters for plotting ROC curves
- Return value for hyperparameter evaluation

1.0.3

Added
- Helpers for controlling logging options when a command line is not
available, such as in notebooks or from test cases
- Helpers for pytorch, including early stopping based on validation set
performance

Updated
- Binary ML metrics to include precision-recall curves
- Optional progress bar when collecting dask results

Fixed
- Safely load YAML config files

1.0.2

Added
- Additional documentation
- Helper for plotting binary prediction scores
- precisionk metric for ML ranking tasks
- Helper to extract dask command line options as an array. Presumably
these would be used in `subprocess.call` or for similar uses.
- Helper to plot mean ROC curves, including shading for the standard
deviation

Updated
- Helper for plotting ROC curves to handle arrays of colors
- Binary classification metrics helper to include points needed for
plotting ROC curves (`sklearn.metrics.roc_curve`)

Fixed
- `logging_utils` to properly quote extracted command line options.
- Missing import in `validation_utils`

1.0.1

Added
- Helper for `xgboost`
- Additional documentation

1.0.0

This version change significantly rearranges the package structure. In particular,
the functionality of the large `utils` and `math_utils` modules has been split
into more specific modules (some of which already existed). Deprecated functionality
has been removed, and sphinx documentation has been added.

Additionally, the package was renamed from `pymisc-utils` to `pyllars` to help
avoid confusion between the older API and the updated one.

This update also adds Travis CI, Coveralls, Read the Docs, and PyPI support for
the project.

The tests are very minimal, and it is expected that some import errors have
not yet been resolved.

[0.99.xyz]
These versions are technical changes between the 0.2.xx and 1.xx code base.
Please ignore these.

Page 1 of 4

© 2024 Safety CLI Cybersecurity Inc. All Rights Reserved.