PyPi: Mako

CVE-2022-40023

Safety vulnerability ID: 50870

This vulnerability was reviewed by experts

The information on this page was manually curated by our Cybersecurity Intelligence Team.

Created at Sep 07, 2022 Updated at May 14, 2024
Scan your Python projects for vulnerabilities →

Advisory

Mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
https://pyup.io/posts/pyup-discovers-redos-vulnerabilities-in-top-python-packages

Affected package

mako

Latest version: 1.3.5

A super-fast templating language that borrows the best ideas from the existing templating languages.

Affected versions

Fixed versions

Vulnerability changelog

This vulnerability has no description

Resources

Use this package?

Scan your Python project for dependency vulnerabilities in two minutes

Scan your application

Severity Details

CVSS Base Score

HIGH 7.5

CVSS v3 Details

HIGH 7.5
Attack Vector (AV)
NETWORK
Attack Complexity (AC)
LOW
Privileges Required (PR)
NONE
User Interaction (UI)
NONE
Scope (S)
UNCHANGED
Confidentiality Impact (C)
NONE
Integrity Impact (I)
NONE
Availability Availability (A)
HIGH