~~~~~~~~~~~~~~~~~~~~~~~~~~~
More internal Laying improvements for the ansible collections (and general readability improvements).
No improvements for CLI users.
* Additional Layer handling improvements for AppPackager and LayerCombiner.
Primary benefits of these internal improvements are for the ``ksconf_package`` command in the `cdillc.splunk`_ collection, and anyone who has to look at the code.
* Replace all ``LayerRoot*`` terminology with ``LayerCollection`` to reduce confusion.
The term _root_ was used multiple places within the layering system to both a top-level folder, as well as a container of layers.
* Replace confusing nested ``Layer`` class structure for a more traditional flat one.
* Add a convenience function for LayerCollection creation (that handles various layering schemes).
* Add :py:method:~`ksconf.layer.LayerFilter.add_rules` to simplify frequent use case.